nixos-old/user.nix

223 lines
3.6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ pkgs, supercolor, kaokao, ... }:
let my-python-packages = p: with p; [ pytest i3ipc python-lsp-server ];
in {
# Define a user account. Don't forget to set a password with passwd.
users.users.zoe = {
shell = pkgs.fish;
isNormalUser = true;
description = "zoe";
extraGroups = [
"networkmanager"
"wheel"
"libvirtd"
"dialout"
"adbusers"
"user-with-access-to-virtualbox"
];
packages = with pkgs; [
# internet
firefox
firefox-devedition
ungoogled-chromium
qutebrowser
curl
git
networkmanagerapplet
thunderbird
tor-browser-bundle-bin
onionshare-gui
mullvad-vpn
syncthing
qbittorrent
telegram-desktop
discord
# files and partitions
gnome.gnome-disk-utility
gnome.nautilus
xfce.thunar
p7zip
unzip
tree
writedisk
postgresql
# music / sound
cmus
pavucontrol
playerctl
pamixer
projectm
picard
audacity
qjackctl
# video
syncplay
mpv
yt-dlp
youtube-dl
obs-studio
ffmpeg_6-full
kdenlive
vulkan-tools
# images
swaybg
gnome.eog
gimp
krita
gnome.cheese
flameshot
aseprite-unfree
# pdf
evince
xournalpp
# games
mgba
steam
pcsx2
dolphin-emu
sc-controller
minetest
airshipper
lutris
# x11
xdotool
arandr
lxappearance
wacomtablet
# terminal
kitty
supercolor.packages.${pkgs.system}.default
kaokao.packages.${pkgs.system}.default
thefuck
lsd
bat
fd
fzf
tmux
# window manager
grim
slurp
swappy
autotiling
wdisplays
xdg-desktop-portal-wlr
xdg-desktop-portal
# uni
dbeaver
zoom-us
haskellPackages.Monadoro
typst
typst-lsp
libreoffice
# spelling
hunspell
hunspellDicts.en_US
hunspellDicts.de_DE
espeak-classic
#3d print
prusa-slicer
#font
fontforge-gtk
# dev
postman
tokei
vscode
mdbook
## nix
any-nix-shell
nixfmt
nil
## js
nodejs
nodePackages.prettier
nodePackages.typescript-language-server
nodePackages.live-server
nodePackages_latest.vscode-langservers-extracted
nodePackages_latest.svelte-language-server
nodePackages_latest.svelte-check
## rust
sqlx-cli
rustup
cargo-watch
llvmPackages_rocm.clang
llvmPackages_rocm.llvm
mold
libclang
taplo
cargo-outdated
cargo-generate
## go
air
go
gopls
delve
## swagger
openapi-generator-cli
## python
(python311.withPackages my-python-packages)
python39
black
## dotlang
graphviz
## 3d
blender
blockbench-electron
## arduino
arduino
## tilemap editor
ldtk
## android
android-tools
# help
tealdeer
# nix tools
## formatter for .nix files
nixpkgs-fmt
## find nix packages containing certain files
nix-index
# system tools
mesa-demos
wl-clipboard
jq
eva
xf86_input_wacom
xorg.xkill
neofetch
htop
bat
du-dust
gnome.gnome-clocks
blueberry
killall
appimage-run
xclip
zip
bottom
tmux
zellij
sshfs
unp
];
};
}